ArticleWhat version of OpenCart you have to use for a new store?

Sorry for my English! English is not my native language. One of the reasons to create this blog is to improve my English writing. So I will be highly obliged if you will help me with this. If you find a grammar error on this page, please select it with your mouse and press Ctrl+Enter.

I often get this question: "What version of OpenCart is the best for the new store? Is it the latest one?" I'll write a few words about it.

On the one hand, the latest version is really the best choice because it is safer and more functional. 
 
But on the other hand, the latest version in not always the best, because store is not just a bare OpenCart, for good store you need to install dozens of modules on it. But the latest version has one big flaw - it doesn't have a lot of modules. Especially when the next version is very different from the previous one, as OpenCart 1.4 differs from OpenCart 1.5 or OpenCart 1.5 differs from OpenCart 2.0.
 
In this case the best version for the new store is the second last which has many modules. Some modules you can find on the OpenCart modules page of this blog :) 
 
So now 18.11.2014 the best version for the new store is OpenCart 1.5.6.4.
In 2-3 months the best version probably will be new with many modules OpenCart 2.0.

 

Add new comment

CAPTCHA
Spam protection
Image CAPTCHA
Enter the characters shown in the image.
You are reporting a typo in the following text:
Simply click the "Send typo report" button to complete the report. You can also include a comment.